install node-sass出错,提示not found: python2

分类: Vue

构建vue.js项目,下载依赖的node-sass模块。但不管npm install还是单独npm install node-sass都报找不到python的错误。

重点是我本地已经安装了Python了 ,DOS命令下是执行python,输出如下:

C:\Users\Administrator>python
Python 3.6.1 (v3.6.1:69c0db5, Mar 21 2017, 18:41:36) [MSC v.1900 64 bit (AMD64)]
 on win32
Type "help", "copyright", "credits" or "license" for more information.
>>>
 
解决方案

表示node-sass并不需要python2...
我特意把环境变量清空,把python和node都删除,重新安装了python3.6.1(64x)和nodejsv6.10.2然后用cnpm install node-sass --save-dev就直接装上并且可以正常编译sassscss了。。

node-sass是4.5.2,直接cnpm就安装成功了

标签: Vue.js

上一篇: 没有了

下一篇: vee-validate 表单验证

by 2019-04-13 19:40:48

0 条评论